Pidgin и война с ICQ

На днях AOL предприняла очередную попытку избавиться от неофициальных клиентов. Что самое странное, сделать они это хотели только с некоторыми странами. Россия, Украина и ряд других стран СНГ. Но к вечеру того же дня уже было выпущено первое лекарство для Miranda и QIP. Теперь очередь дошла и до Pidgin.

Есть три способа для исправления сложившейся ситуации:
1. Быстрый. Для ленивых владельцев 32-битных систем.
Скачайте архив liboscar.so.0.0.0.tar.bz2 и распакуйте его в папку /usr/lib/purple-2. Не забудьте перед этой процедурой сделать копию уже имеющегося в директории файла. Проверка работоспособности осуществлялась на версии 2.5.2, но должно работать и на 2.5.4.

2. Долгий. Для любителей всё делать самостоятельно и для тех кому не подошёл предыдущий способ.
а) Скачиваем исходники Pidgin и патча.

б) Устанавливаем необходимые для сборки пакеты (это всё одна строка)

sudo aptitude install libglib2.0-dev libgtk2.0-dev libxss-dev libstartup-notification0-dev libgtkspell-dev libxml2-dev libgstreamer0.10-dev libmeanwhile-dev libavahi-ui-dev libdbus-glib-1-dev network-manager-dev libperl-dev libgnutls-dev tcl-dev tk-dev

в) Распаковываем архив с Pidgin

tar xvfj pidgin-2.5.4.tar.bz2

г) Применяем патч

patch < pidgin-NOT-UPSTREAM-2.5.4-icq-russia.patch

д) Конфигурируем, собираем и устанавливаем Pidgin (это две строки)

./configure —prefix=/opt/ && make
sudo make install

е) Запускаем Pidgin

/opt/bin/pidgin

3. Правильный. Рекомендуется, так как рано или поздно это сделать придётся.
Поступить как я. Перестать пользоваться ICQ и перейти на Jabber. Это проще чем кажется! Очень хорошая статья о переходе на Jabber написана на ресурсе Хабрахабр: Я бы в Джабберы пошёл…

По мотивам статьи Патчим и собираем pidgin на дому.

Обновление от 05 февраля 2009 11:56
Есть ещё вариант запуска ICQ через tor. Делается это так:

sudo apt-get install tor

А затем в настройках ICQ указываем:

  • socks: 5
  • узел: localhost
  • порт: 9050

Сам не пробовал, так как я воспользовался 3 вариантом решения проблемы.

Pidgin и ICQ в Ubuntu

ICQ Logo / MeAndUbuntu.Blogspot.ComВ связи с внедрением AOL (компании владеющей ICQ) новой версии протокола (Oscar 6) все клиенты с иными версиями протокола не могут связаться с сервером. Есть несколько выходов из этой ситуации:
1. Начать использовать Jabber и соединяться с ICQ через ICQ-транспорт;
2. Скачать новую версию Pidgin (2.4.3) в исходных кодах и собрать его самостоятельно;
3. Найти уже собранный deb-пакет с Pidgin.

Или есть ещё один вариант:

4. Заменить всего один файл в /usr/lib/purple-2/

Вариант 4 работает и в Ubuntu 7.10 и в Ubuntu 8.04.

P.S.
Сегодня ещё наткнулся на deb-пакеты самого Pidgin и библиотеки отвечающей за протоколы связи для Ubuntu 8.04. Их устанавливать не пробовал, но если кто установит, то милости прошу рассказать свои впечатления и ощущения в комментариях. А вот и сами пакеты:
Версия для 32 битных Операционных Систем (i386)
pidgin_2.4.3-1~getdeb1_i386.deb
libpurple0_2.4.3-1~getdeb1_i386.deb

Версия для 64 битных Операционных Систем (amd64)
pidgin_2.4.3-1~getdeb1_amd64.deb
libpurple0_2.4.3-1~getdeb1_amd64.deb